north-memo

数学できない方の数学科のブログ、一応デザイナー…なのか…?

今日の進捗

今日やったこと

引っかかったこと

Heroku toolbeltがインストール出来ない

  • もともと入ってたrubyのバージョンが低すぎる

PostgreSQLが入らない( gem install pg が出来ない)

  • sudo yum install postgresql postgresql-develで解決

rails s をしてもブラウザからアクセス出来ない問題

  • iptablesでport開いてもダメ
  • rails s -b 0.0.0.0でもだめ
  • vagrantのHostとguestを3000にしてもダメ
  • 仮想環境上でwgetとかcurlとかはOK 未解決…。ドットインストールのように全く進まなくて泣ける。5時間近くやったが解決しないのでRubyとかRailsとか嫌いになりそう…。

おまけ

rbenv

  • 次のコマンドでインストール候補を表示できる
    rbenv install -l
  • 次のコマンドでこのバージョンのrubyをインストール
    rbenv install バージョン名
  • 最後にこのコマンドで切り替え
    rbenv global バージョン名

railsのインストールの仕方

gem install rails

railsの使い方

  • 新しいアプリケーションの作成
    rails new アプリ名 [option]

今回は rails new mymemo -d PostgreSQL としたが、 -d はデータベースの選択のよう

参考にした記事